Fedora 11 Adobe Air Installation “Not allowed by administrator”

Download the Adobe Air “.bin” file here.

Open terminal and cd to the location of the .bin file.

Add executable permissions on the bin file:

chmod +x AdobeAirInstaller.bin

Run the bin file (dot slash filename):

./AdobeAirInstaller.bin

Not Allowed By Administrator

An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator.

This problem occurs due to missing packages.

How to fix? Install the following:

yum -y install xterm gtk2-devel gnome-keyring libxml2-devel libxslt rpm-devel nss

Then run the .bin file again.

[xterm might be needed for a pop up terminal requesting a root password when installing air or air apps]

xterm

That’s it.

Comment if this helped!

Advertisements

~ by Fresh on June 24, 2009.

14 Responses to “Fedora 11 Adobe Air Installation “Not allowed by administrator””

  1. You rock! I was banging my head over this one. It worked so simply after the missing packages were installed.

    Thanks!

  2. QL!

  3. Dood,

    You rock! Couldn’t work out why I was getting the error either!
    But this solution solved the problem quickly and simply! thank you!

    P.S. Doesn’t the new Fedora 11 totally kick ass!! 🙂

  4. If you’re on an x86-64 platform, you’ll need to install the 32-bit versions for most of these RPMs since Adobe AIR 1.5 is a 32-bit application. For example:

    yum -y install rpm-devel.i586

  5. I had installed them before but with KPackageKit, but something must not have done it correctly. Did the instructions above using yum and it worked great, thanks for figuring this out 🙂

  6. Awesome! Thumbs up!

  7. […] googling stumbled me upon this site which provided the fix. All credits to him. Yum these […]

  8. cannot imagine there are such many important packages missing by the default installation. Thanks for your tip, it fixes.

  9. I meticulously followed the instructions in the original post and installed the missing 32/64-bit packages, but i get the following error: “An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator.” could this be an SELinux issue?

  10. …thanks a lot! it made my day.

  11. more detailed fix please

  12. um im not really genius in computers…. whats yum -y install xterm gtk2-devel gnome-keyring libxml2-devel libxslt rpm-devel nss ??

  13. oh would that be anything different cos I use windows

  14. plz tell the detailed process 😦

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: